summaryrefslogtreecommitdiffstats
path: root/twin/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
commit92841ae8b62560f0b137dc838bfd12ac78d26599 (patch)
tree77ff1aee27f10b9ba54d6c6e1f4d972c72d69b67 /twin/CMakeLists.txt
parent191cf4812dfa7524f32916423d79f072d88f56d1 (diff)
downloadtdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.tar.gz
tdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 2f706891f32258c2b070471905f983e4585296d2)
Diffstat (limited to 'twin/CMakeLists.txt')
-rw-r--r--twin/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/twin/CMakeLists.txt b/twin/CMakeLists.txt
index 7b4badc6c..33a2302e4 100644
--- a/twin/CMakeLists.txt
+++ b/twin/CMakeLists.txt
@@ -43,7 +43,13 @@ install( FILES KWinInterface.h DESTINATION ${INCLUDE_INSTALL_DIR} )
##### other data ################################
tde_install_icons( twin )
-install( FILES eventsrc DESTINATION ${DATA_INSTALL_DIR}/twin )
+
+tde_create_translated_desktop(
+ SOURCE eventsrc
+ DESTINATION ${DATA_INSTALL_DIR}/twin
+ PO_DIR twin-eventsrc
+)
+
install( FILES twin.kcfg DESTINATION ${KCFG_INSTALL_DIR} )