summaryrefslogtreecommitdiffstats
path: root/kappfinder/apps/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kappfinder/apps/CMakeLists.txt')
-rw-r--r--kappfinder/apps/CMakeLists.txt22
1 files changed, 14 insertions, 8 deletions
diff --git a/kappfinder/apps/CMakeLists.txt b/kappfinder/apps/CMakeLists.txt
index 0b154cc1a..0f6a04f21 100644
--- a/kappfinder/apps/CMakeLists.txt
+++ b/kappfinder/apps/CMakeLists.txt
@@ -3,17 +3,23 @@
# (C) 2010-2011 Serghei Amelian
# serghei (DOT) amelian (AT) gmail.com
#
+# (C) 2020 Slávek Banko
+# slavek.banko (AT) axis.cz
+#
# Improvements and feedback are welcome
#
# This file is released under GPL >= 2
#
#################################################
-add_subdirectory( Internet )
-add_subdirectory( Development )
-add_subdirectory( Graphics )
-add_subdirectory( System )
-add_subdirectory( Utilities )
-add_subdirectory( Office )
-add_subdirectory( Multimedia )
-add_subdirectory( Games )
+file( GLOB_RECURSE _desktops RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.desktop )
+list( SORT _desktops )
+
+foreach( _desktop IN LISTS _desktops )
+ get_filename_component( _category ${_desktop} PATH )
+ tde_create_translated_desktop(
+ SOURCE ${_desktop}
+ DESTINATION ${DATA_INSTALL_DIR}/kappfinder/apps/${_category}
+ PO_DIR kappfinder-data
+ )
+endforeach()