summaryrefslogtreecommitdiffstats
path: root/kcontrol/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kcontrol/Makefile.am')
-rw-r--r--kcontrol/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/kcontrol/Makefile.am b/kcontrol/Makefile.am
new file mode 100644
index 000000000..50e8242de
--- /dev/null
+++ b/kcontrol/Makefile.am
@@ -0,0 +1,39 @@
+
+if include_kcontrol_access
+ACCESS_SUBDIR=access
+endif
+
+if include_kcontrol_kfontinst
+FONTINST_SUBDIR=kfontinst
+endif
+
+if include_kcontrol_smartcard
+KSMCARD_SUBDIR=smartcard
+endif
+
+if include_kcontrol_usbview
+USBVIEW_SUBDIR=usbview
+endif
+
+if include_kcontrol_view1394
+VIEW1394_SUBDIR=view1394
+endif
+
+if include_kcontrol_randr
+RANDR_SUBDIR=randr
+endif
+
+if include_kcontrol_joystick
+JOYSTICK_SUBDIR=joystick
+endif
+
+# 'colors' and 'fonts' should come after 'krdb'
+SUBDIRS = bell background dnssd filetypes samba krdb input info ioslaveinfo kdm\
+ kicker locale launch keys kio konq style kded \
+ konqhtml ebrowsing arts kcontrol knotify\
+ clock pics $(ACCESS_SUBDIR) colors energy fonts css \
+ icons screensaver taskbar crypto privacy smserver \
+ konsole spellchecking $(USBVIEW_SUBDIR) \
+ $(KSMCARD_SUBDIR) nics $(FONTINST_SUBDIR) $(RANDR_SUBDIR) \
+ componentchooser performance xinerama $(VIEW1394_SUBDIR) display kthememanager \
+ $(JOYSTICK_SUBDIR)