summaryrefslogtreecommitdiffstats
path: root/kcontrol/arts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kcontrol/arts/Makefile.am')
-rw-r--r--kcontrol/arts/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/kcontrol/arts/Makefile.am b/kcontrol/arts/Makefile.am
new file mode 100644
index 000000000..f4b68cfa1
--- /dev/null
+++ b/kcontrol/arts/Makefile.am
@@ -0,0 +1,15 @@
+kde_module_LTLIBRARIES = kcm_arts.la
+
+kcm_arts_la_SOURCES = arts.cpp generaltab.ui hardwaretab.ui krichtextlabel.cpp
+
+kcm_arts_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+kcm_arts_la_LIBADD = $(LIB_KIO) $(LIB_KUTILS) -lkmid
+
+AM_CPPFLAGS = -I$(kde_includes)/arts $(all_includes)
+
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmarts.pot
+
+xdg_apps_DATA = arts.desktop