summaryrefslogtreecommitdiffstats
path: root/kcontrol/background/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kcontrol/background/CMakeLists.txt')
-rw-r--r--kcontrol/background/CMakeLists.txt63
1 files changed, 63 insertions, 0 deletions
diff --git a/kcontrol/background/CMakeLists.txt b/kcontrol/background/CMakeLists.txt
new file mode 100644
index 000000000..693d6330c
--- /dev/null
+++ b/kcontrol/background/CMakeLists.txt
@@ -0,0 +1,63 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+if( BUILD_KCONTROL OR BUILD_KDESKTOP OR BUILD_KDM )
+
+ include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/libkonq
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ )
+
+ link_directories(
+ ${TQT_LIBRARY_DIRS}
+ )
+
+ ##### bgnd (static) #############################
+
+ tde_add_library( bgnd STATIC_PIC AUTOMOC
+ SOURCES bgrender.cpp bgsettings.cpp
+ )
+
+endif( )
+
+
+if( BUILD_KCONTROL )
+
+ add_subdirectory( pics )
+
+ ##### other data ################################
+
+ install( FILES background.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+
+
+ ##### kcm_background (module) ###################
+
+ tde_add_kpart( kcm_background AUTOMOC
+ SOURCES main.cpp
+ LINK kcmbgnd-static bgnd-static knewstuff-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+ )
+
+
+ ##### kcmbgnd (static) ##########################
+
+ tde_add_library( kcmbgnd STATIC_PIC AUTOMOC
+ SOURCES
+ bgdialog.cpp bgdialog_ui.ui bgwallpaper_ui.ui
+ bgwallpaper.cpp bgadvanced_ui.ui bgadvanced.cpp
+ bgmonitor.cpp
+ )
+
+endif( )