summaryrefslogtreecommitdiffstats
path: root/kcontrol/colors/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kcontrol/colors/Makefile.am')
-rw-r--r--kcontrol/colors/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/kcontrol/colors/Makefile.am b/kcontrol/colors/Makefile.am
new file mode 100644
index 000000000..87f4048ef
--- /dev/null
+++ b/kcontrol/colors/Makefile.am
@@ -0,0 +1,15 @@
+AM_CPPFLAGS = $(all_includes)
+
+kde_module_LTLIBRARIES = kcm_colors.la
+
+kcm_colors_la_SOURCES = colorscm.cpp widgetcanvas.cpp
+kcm_colors_la_LDFLAGS = $(KDE_RPATH) -module -avoid-version $(all_libraries) -no-undefined
+kcm_colors_la_LIBADD = $(LIB_KDEUI) $(LIB_KIO) $(top_builddir)/kcontrol/krdb/libkrdb.la
+METASOURCES = colorscm.moc widgetcanvas.moc
+
+noinst_HEADERS = colorscm.h widgetcanvas.h
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kcmcolors.pot
+
+xdg_apps_DATA = colors.desktop