summaryrefslogtreecommitdiffstats
path: root/kcontrol/componentchooser/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kcontrol/componentchooser/Makefile.am')
-rw-r--r--kcontrol/componentchooser/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/kcontrol/componentchooser/Makefile.am b/kcontrol/componentchooser/Makefile.am
new file mode 100644
index 000000000..3a63947a0
--- /dev/null
+++ b/kcontrol/componentchooser/Makefile.am
@@ -0,0 +1,15 @@
+SUBDIRS= . componentservices
+AM_CPPFLAGS = -I../ -I$(top_srcdir)/kio -I$(top_srcdir) $(all_includes)
+
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = kcm_componentchooser.la
+
+kcm_componentchooser_la_SOURCES = componentchooser_ui.ui componentconfig_ui.ui emailclientconfig_ui.ui terminalemulatorconfig_ui.ui browserconfig_ui.ui componentchooser.cpp kcm_componentchooser.cpp
+kcm_componentchooser_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+kcm_componentchooser_la_LIBADD = $(LIB_KIO)
+
+xdg_apps_DATA = componentchooser.desktop
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmcomponentchooser.pot