summaryrefslogtreecommitdiffstats
path: root/kcontrol/css/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kcontrol/css/CMakeLists.txt')
-rw-r--r--kcontrol/css/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/kcontrol/css/CMakeLists.txt b/kcontrol/css/CMakeLists.txt
new file mode 100644
index 000000000..f5410f187
--- /dev/null
+++ b/kcontrol/css/CMakeLists.txt
@@ -0,0 +1,34 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+##### other data ################################
+
+install( FILES kcmcss.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+install( FILES template.css DESTINATION ${DATA_INSTALL_DIR}/kcmcss )
+
+
+##### kcm_css (module) ##########################
+
+tde_add_kpart( kcm_css AUTOMOC
+ SOURCES template.cpp cssconfig.ui csscustom.ui kcmcss.cpp preview.ui
+ LINK kio-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)