summaryrefslogtreecommitdiffstats
path: root/kcontrol/css/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kcontrol/css/Makefile.am')
-rw-r--r--kcontrol/css/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/kcontrol/css/Makefile.am b/kcontrol/css/Makefile.am
new file mode 100644
index 000000000..9f55b5a75
--- /dev/null
+++ b/kcontrol/css/Makefile.am
@@ -0,0 +1,16 @@
+AM_CPPFLAGS = $(all_includes)
+
+template_DATA = template.css
+templatedir = $(kde_datadir)/kcmcss
+
+kde_module_LTLIBRARIES = kcm_css.la
+kcm_css_la_SOURCES = template.cpp cssconfig.ui csscustom.ui kcmcss.cpp preview.ui
+kcm_css_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+kcm_css_la_LIBADD = -lkdeui $(LIB_KIO)
+
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmcss.pot
+
+xdg_apps_DATA = kcmcss.desktop