summaryrefslogtreecommitdiffstats
path: root/kcontrol/ebrowsing/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kcontrol/ebrowsing/Makefile.am')
-rw-r--r--kcontrol/ebrowsing/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/kcontrol/ebrowsing/Makefile.am b/kcontrol/ebrowsing/Makefile.am
new file mode 100644
index 000000000..dfb9fdbe8
--- /dev/null
+++ b/kcontrol/ebrowsing/Makefile.am
@@ -0,0 +1,21 @@
+
+SUBDIRS = plugins
+
+AM_CPPFLAGS = -I$(srcdir)/plugins/ikws $(all_includes)
+
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = kcm_kurifilt.la
+kcm_kurifilt_la_SOURCES = filteropts.cpp main.cpp
+
+kcm_kurifilt_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+kcm_kurifilt_la_LIBADD = $(LIB_KSYCOCA)
+# Don't link this lib to the plugins. They are dlopened and linking to them
+# results in crashes when closing kcmshell.
+# plugins/ikws/libkuriikwsfilter.la plugins/shorturi/libkshorturifilter.la
+
+messages: rc.cpp
+ $(EXTRACTRC) plugins/*/*.ui >> rc.cpp
+ $(XGETTEXT) *.cpp plugins/ikws/*.cpp plugins/shorturi/*.cpp -o $(podir)/kcmkurifilt.pot
+
+xdg_apps_DATA = ebrowsing.desktop