summaryrefslogtreecommitdiffstats
path: root/kcontrol/ebrowsing/plugins/localdomain/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kcontrol/ebrowsing/plugins/localdomain/Makefile.am')
-rw-r--r--kcontrol/ebrowsing/plugins/localdomain/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/kcontrol/ebrowsing/plugins/localdomain/Makefile.am b/kcontrol/ebrowsing/plugins/localdomain/Makefile.am
new file mode 100644
index 000000000..cb524dd4b
--- /dev/null
+++ b/kcontrol/ebrowsing/plugins/localdomain/Makefile.am
@@ -0,0 +1,20 @@
+## Makefile.am of kdebase/kcontrol/ebrowsing/plugins/localdomain
+
+AM_CPPFLAGS = $(all_includes) -DQT_NO_CAST_ASCII
+
+kde_module_LTLIBRARIES = liblocaldomainurifilter.la
+
+liblocaldomainurifilter_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+liblocaldomainurifilter_la_LIBADD = $(LIB_KIO) $(LIB_KDEUI) $(LIB_KDECORE)
+
+liblocaldomainurifilter_la_SOURCES = localdomainurifilter.cpp localdomainurifilter.skel
+
+service_DATA = localdomainurifilter.desktop
+servicedir = $(kde_servicesdir)
+
+METASOURCES = AUTO
+
+bin_PROGRAMS = klocaldomainurifilterhelper
+
+klocaldomainurifilterhelper_SOURCES = klocaldomainurifilterhelper.c
+klocaldomainurifilterhelper_LDADD = $(LIBSOCKET)