summaryrefslogtreecommitdiffstats
path: root/kcontrol/ebrowsing/plugins/shorturi/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kcontrol/ebrowsing/plugins/shorturi/CMakeLists.txt')
-rw-r--r--kcontrol/ebrowsing/plugins/shorturi/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/kcontrol/ebrowsing/plugins/shorturi/CMakeLists.txt b/kcontrol/ebrowsing/plugins/shorturi/CMakeLists.txt
new file mode 100644
index 000000000..c8d25b1bf
--- /dev/null
+++ b/kcontrol/ebrowsing/plugins/shorturi/CMakeLists.txt
@@ -0,0 +1,34 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+##### other data ################################
+
+install( FILES kshorturifilter.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+install( FILES kshorturifilterrc DESTINATION ${CONFIG_INSTALL_DIR} )
+
+
+##### libkshorturifilter (module) ###############
+
+tde_add_kpart( libkshorturifilter AUTOMOC
+ SOURCES kshorturifilter.cpp kshorturifilter.skel
+ LINK kio-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)