summaryrefslogtreecommitdiffstats
path: root/kcontrol/energy/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kcontrol/energy/CMakeLists.txt')
-rw-r--r--kcontrol/energy/CMakeLists.txt65
1 files changed, 65 insertions, 0 deletions
diff --git a/kcontrol/energy/CMakeLists.txt b/kcontrol/energy/CMakeLists.txt
new file mode 100644
index 000000000..ee9bf8ab0
--- /dev/null
+++ b/kcontrol/energy/CMakeLists.txt
@@ -0,0 +1,65 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+option( WITH_DPMS "Enable DPMS power saving" ON )
+
+if( WITH_DPMS )
+
+ include( CheckCSourceCompiles )
+
+ set( CMAKE_REQUIRED_LIBRARIES Xext )
+
+ check_c_source_compiles("
+ #include <sys/types.h>
+ #include <netinet/in.h>
+ #include <arpa/nameser.h>
+ #include <resolv.h>
+ #include <X11/Xproto.h>
+ #include <X11/X.h>
+ #include <X11/Xlib.h>
+ #include <X11/extensions/dpms.h>
+ int main()
+ { return DPMSSetTimeouts( 0, 0, 0, 0 ); }"
+ HAVE_DPMS )
+
+ if( NOT HAVE_DPMS )
+ tde_message_fatal( "DPMS support are requested, but is not detected on you system.\n libXext (and its devel package) are installed?" )
+ endif()
+
+ set( XEXT_LIBRARY Xext )
+
+endif()
+
+add_subdirectory( pics )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+##### other data ################################
+
+install( FILES energy.desktop DESTINATION ${APPS_INSTALL_DIR}/.hidden )
+
+
+##### kcm_energy (module) #######################
+
+tde_add_kpart( kcm_energy AUTOMOC
+ SOURCES energy.cpp
+ LINK kio-shared ${XEXT_LIBRARY}
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)