summaryrefslogtreecommitdiffstats
path: root/kcontrol/info/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kcontrol/info/CMakeLists.txt')
-rw-r--r--kcontrol/info/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/kcontrol/info/CMakeLists.txt b/kcontrol/info/CMakeLists.txt
new file mode 100644
index 000000000..531f52780
--- /dev/null
+++ b/kcontrol/info/CMakeLists.txt
@@ -0,0 +1,41 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+# FIXME no OPENGL support yet
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+##### other data ################################
+
+install( FILES
+ memory.desktop processor.desktop dma.desktop
+ interrupts.desktop ioports.desktop opengl.desktop
+ pci.desktop sound.desktop devices.desktop scsi.desktop
+ partitions.desktop xserver.desktop cdinfo.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR} )
+
+
+##### kcm_info (module) #########################
+
+tde_add_kpart( kcm_info AUTOMOC
+ SOURCES main.cpp memory.cpp opengl.cpp
+ LINK kdeui-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)