summaryrefslogtreecommitdiffstats
path: root/kcontrol/kded/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kcontrol/kded/Makefile.am')
-rw-r--r--kcontrol/kded/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/kcontrol/kded/Makefile.am b/kcontrol/kded/Makefile.am
new file mode 100644
index 000000000..af2d54142
--- /dev/null
+++ b/kcontrol/kded/Makefile.am
@@ -0,0 +1,15 @@
+kde_module_LTLIBRARIES = kcm_kded.la
+
+kcm_kded_la_SOURCES = kcmkded.cpp
+
+kcm_kded_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+kcm_kded_la_LIBADD = $(LIB_KIO)
+
+AM_CPPFLAGS= $(all_includes)
+
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmkded.pot
+
+xdg_apps_DATA = kcmkded.desktop