summaryrefslogtreecommitdiffstats
path: root/kcontrol/konsole/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kcontrol/konsole/Makefile.am')
-rw-r--r--kcontrol/konsole/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/kcontrol/konsole/Makefile.am b/kcontrol/konsole/Makefile.am
new file mode 100644
index 000000000..622e7fa71
--- /dev/null
+++ b/kcontrol/konsole/Makefile.am
@@ -0,0 +1,18 @@
+kde_module_LTLIBRARIES = kcm_konsole.la
+
+kcm_konsole_la_SOURCES = schemaeditor.cpp sessioneditor.cpp kcmkonsole.cpp \
+ schemadialog.ui sessiondialog.ui kcmkonsoledialog.ui
+
+kcm_konsole_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+kcm_konsole_la_LIBADD = -lkdeui $(LIB_KIO)
+AM_CPPFLAGS = $(all_includes)
+
+METASOURCES = AUTO
+
+noinst_HEADERS = kcmkonsole.h schemaeditor.h sessioneditor.h schemadialog.h sessiondialog.h kcmkonsoledialog.h
+
+kcmkonsole_data_DATA = kcmkonsole.desktop
+kcmkonsole_datadir = $(kde_appsdir)/.hidden
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmkonsole.pot