summaryrefslogtreecommitdiffstats
path: root/kcontrol/nics/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kcontrol/nics/CMakeLists.txt')
-rw-r--r--kcontrol/nics/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/kcontrol/nics/CMakeLists.txt b/kcontrol/nics/CMakeLists.txt
new file mode 100644
index 000000000..6d2c8e675
--- /dev/null
+++ b/kcontrol/nics/CMakeLists.txt
@@ -0,0 +1,41 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include( CheckFunctionExists )
+
+check_include_file( "sys/sockio.h" HAVE_SYS_SOCKIO_H )
+check_function_exists( getnameinfo HAVE_GETNAMEINFO )
+check_struct_has_member( "struct sockaddr" sa_len "sys/types.h;sys/socket.h" HAVE_STRUCT_SOCKADDR_SA_LEN )
+
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+##### other data ################################
+
+install( FILES nic.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+
+
+##### kcm_nic (module) ##########################
+
+tde_add_kpart( kcm_nic AUTOMOC
+ SOURCES nic.cpp
+ LINK kio-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)