summaryrefslogtreecommitdiffstats
path: root/kcontrol/performance/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kcontrol/performance/Makefile.am')
-rw-r--r--kcontrol/performance/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/kcontrol/performance/Makefile.am b/kcontrol/performance/Makefile.am
new file mode 100644
index 000000000..5ae59d89e
--- /dev/null
+++ b/kcontrol/performance/Makefile.am
@@ -0,0 +1,20 @@
+kde_module_LTLIBRARIES = kcm_performance.la
+
+kcm_performance_la_SOURCES = kcmperformance.cpp konqueror.cpp konqueror_ui.ui system.cpp system_ui.ui
+kcm_performance_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+kcm_performance_la_LIBADD = -lkdeui
+AM_CPPFLAGS= $(all_includes)
+
+METASOURCES = AUTO
+
+noinst_HEADERS = konqueror.h system.h
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmperformance.pot
+
+xdg_apps_DATA = kcmperformance.desktop
+
+kcmperformance_hidden_data_DATA = kcmkonqyperformance.desktop
+kcmperformance_hidden_datadir = $(kde_appsdir)/.hidden
+
+EXTRA_DIST = $(xdg_apps_DATA)