summaryrefslogtreecommitdiffstats
path: root/kcontrol/samba/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kcontrol/samba/Makefile.am')
-rw-r--r--kcontrol/samba/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/kcontrol/samba/Makefile.am b/kcontrol/samba/Makefile.am
new file mode 100644
index 000000000..42c3f6618
--- /dev/null
+++ b/kcontrol/samba/Makefile.am
@@ -0,0 +1,15 @@
+kde_module_LTLIBRARIES = kcm_samba.la
+
+kcm_samba_la_SOURCES = main.cpp ksmbstatus.cpp kcmsambaimports.cpp kcmsambalog.cpp kcmsambastatistics.cpp
+
+kcm_samba_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+kcm_samba_la_LIBADD = $(LIB_KIO)
+
+AM_CPPFLAGS = $(all_includes)
+
+METASOURCES = AUTO
+
+messages:
+ $(XGETTEXT) $(kcm_samba_la_SOURCES) -o $(podir)/kcmsamba.pot
+
+xdg_apps_DATA = smbstatus.desktop