summaryrefslogtreecommitdiffstats
path: root/kcontrol/style/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kcontrol/style/Makefile.am')
-rw-r--r--kcontrol/style/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/kcontrol/style/Makefile.am b/kcontrol/style/Makefile.am
new file mode 100644
index 000000000..27f38de72
--- /dev/null
+++ b/kcontrol/style/Makefile.am
@@ -0,0 +1,18 @@
+
+AM_CPPFLAGS = $(all_includes)
+SUBDIRS = keramik .
+
+kde_module_LTLIBRARIES = kcm_style.la
+
+kcm_style_la_SOURCES = kcmstyle.cpp stylepreview.ui menupreview.cpp styleconfdialog.cpp
+kcm_style_la_LDFLAGS = $(KDE_RPATH) -module -avoid-version $(all_libraries) -no-undefined
+kcm_style_la_LIBADD = $(LIB_KIO) ../krdb/libkrdb.la
+METASOURCES = AUTO
+
+noinst_HEADERS = kcmstyle.h stylepreview.h menupreview.h
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmstyle.pot
+
+xdg_apps_DATA = style.desktop
+