summaryrefslogtreecommitdiffstats
path: root/kcontrol/tdm/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kcontrol/tdm/CMakeLists.txt')
-rw-r--r--kcontrol/tdm/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/kcontrol/tdm/CMakeLists.txt b/kcontrol/tdm/CMakeLists.txt
index 7c2a1f887..4283d0612 100644
--- a/kcontrol/tdm/CMakeLists.txt
+++ b/kcontrol/tdm/CMakeLists.txt
@@ -29,8 +29,7 @@ install( FILES tdm.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
##### kcm_tdm (module) ##########################
-set_source_files_properties( background.cpp PROPERTIES COMPILE_FLAGS -DKDE_CONFDIR=\\"${TDE_CONFIG_DIR}\\" )
-set_source_files_properties( main.cpp PROPERTIES COMPILE_FLAGS -DKDE_CONFDIR=\\"${TDE_CONFIG_DIR}\\" )
+set_property( SOURCE background.cpp main.cpp APPEND PROPERTY COMPILE_DEFINITIONS KDE_CONFDIR="${TDE_CONFIG_DIR}" )
tde_add_kpart( kcm_tdm AUTOMOC
SOURCES