summaryrefslogtreecommitdiffstats
path: root/kdeprint/kdeprintfax/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kdeprint/kdeprintfax/Makefile.am')
-rw-r--r--kdeprint/kdeprintfax/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/kdeprint/kdeprintfax/Makefile.am b/kdeprint/kdeprintfax/Makefile.am
new file mode 100644
index 000000000..c2b072049
--- /dev/null
+++ b/kdeprint/kdeprintfax/Makefile.am
@@ -0,0 +1,23 @@
+INCLUDES= $(all_includes)
+
+bin_PROGRAMS = kdeprintfax
+kdeprintfax_SOURCES = main.cpp kdeprintfax.cpp faxab.cpp faxctrl.cpp confgeneral.cpp configdlg.cpp \
+ conffax.cpp confsystem.cpp conffilters.cpp filterdlg.cpp defcmds.cpp
+kdeprintfax_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+kdeprintfax_LDADD = $(LIB_KDEUI) $(LIB_KIO) $(LIB_KDEPRINT) -lkabc
+kdeprintfax_METASOURCES = AUTO
+
+xdg_apps_DATA = kdeprintfax.desktop
+
+uidir = $(kde_datadir)/kdeprintfax
+ui_DATA = kdeprintfaxui.rc faxfilters
+
+private_SCRIPTS = anytops
+privatedir = $(kde_datadir)/kdeprintfax
+
+messages: rc.cpp
+ $(XGETTEXT) `find . -name \*.h -o -name \*.cpp -o -name \*.cc` -o $(podir)/kdeprintfax.pot
+
+KDE_ICON = kdeprintfax
+pic_ICON = abentry
+picdir = $(kde_datadir)/kdeprintfax/icons