summaryrefslogtreecommitdiffstats
path: root/kdesktop/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kdesktop/CMakeLists.txt')
-rw-r--r--kdesktop/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/kdesktop/CMakeLists.txt b/kdesktop/CMakeLists.txt
index fa3d8547c..99d86d13a 100644
--- a/kdesktop/CMakeLists.txt
+++ b/kdesktop/CMakeLists.txt
@@ -48,7 +48,9 @@ install( FILES
##### other data ################################
-install( FILES kdesktop.desktop DESTINATION ${AUTOSTART_INSTALL_DIR} )
+configure_file( kdesktop.desktop.cmake kdesktop.desktop @ONLY )
+
+install( FILES ${CMAKE_CURRENT_BINARY_DIR}/kdesktop.desktop DESTINATION ${AUTOSTART_INSTALL_DIR} )
install( FILES kdesktop_custom_menu1 kdesktop_custom_menu2 DESTINATION ${CONFIG_INSTALL_DIR} )
install( FILES kdesktopSetAsBackground.desktop DESTINATION ${DATA_INSTALL_DIR}/konqueror/servicemenus )
install( FILES kdesktop.kcfg klaunch.kcfg DESTINATION ${KCFG_INSTALL_DIR} )