summaryrefslogtreecommitdiffstats
path: root/kdesktop/kwebdesktop/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kdesktop/kwebdesktop/CMakeLists.txt')
-rw-r--r--kdesktop/kwebdesktop/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/kdesktop/kwebdesktop/CMakeLists.txt b/kdesktop/kwebdesktop/CMakeLists.txt
new file mode 100644
index 000000000..3df328c0c
--- /dev/null
+++ b/kdesktop/kwebdesktop/CMakeLists.txt
@@ -0,0 +1,42 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES kwebdesktop.desktop DESTINATION ${DATA_INSTALL_DIR}/kdesktop/programs )
+install( FILES kwebdesktop.kcfg DESTINATION ${KCFG_INSTALL_DIR} )
+
+
+##### kwebdesktop (executable) ##################
+
+set( target kwebdesktop )
+
+set( ${target}_SRCS
+ kwebdesktop.cpp kwebdesktopsettings.kcfgc
+)
+
+tde_add_executable( ${target} AUTOMOC
+ SOURCES ${${target}_SRCS}
+ LINK khtml-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)