summaryrefslogtreecommitdiffstats
path: root/kdm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kdm/Makefile.am')
-rw-r--r--kdm/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/kdm/Makefile.am b/kdm/Makefile.am
new file mode 100644
index 000000000..106e47862
--- /dev/null
+++ b/kdm/Makefile.am
@@ -0,0 +1,20 @@
+SUBDIRS = . backend kfrontend
+
+PAM = @KDM_PAM_SERVICE@
+
+noinst_DATA=config.ci
+
+kdmdocdir = $(datadir)/doc/kdm
+kdmdoc_DATA = README
+
+install-data-local:
+ -@test -n "$(DESTDIR)" || test -z "$(PAM)" || { $(top_srcdir)/mkpamserv $(PAM) && $(top_srcdir)/mkpamserv -P $(PAM)-np; }
+
+config.ci: $(srcdir)/config.def $(srcdir)/confproc.pl
+ $(PERL) -w $(srcdir)/confproc.pl $(srcdir)/config.def $@
+
+CLEANFILES = config.ci
+
+### this is *only* for the kdm home page maintainer! ###
+hp:
+ scp README ChangeLog TODO devel-home:files/kdm