summaryrefslogtreecommitdiffstats
path: root/kdmlib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kdmlib/Makefile.am')
-rw-r--r--kdmlib/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/kdmlib/Makefile.am b/kdmlib/Makefile.am
index 91218a8c3..eedb681bc 100644
--- a/kdmlib/Makefile.am
+++ b/kdmlib/Makefile.am
@@ -1,11 +1,15 @@
AM_CPPFLAGS = -I$(top_srcdir)/kdm/kfrontend $(all_includes)
-kde_module_LTLIBRARIES = kgreet_classic.la kgreet_winbind.la
+kde_module_LTLIBRARIES = kgreet_classic.la kgreet_pam.la kgreet_winbind.la
kgreet_classic_la_SOURCES = kgreet_classic.cpp
kgreet_classic_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN) $(all_libraries)
kgreet_classic_la_LIBADD = $(LIB_KDEUI)
+kgreet_pam_la_SOURCES = kgreet_pam.cpp
+kgreet_pam_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN) $(all_libraries)
+kgreet_pam_la_LIBADD = $(LIB_KDEUI)
+
kgreet_winbind_la_SOURCES = kgreet_winbind.cpp
kgreet_winbind_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN) $(all_libraries)
kgreet_winbind_la_LIBADD = $(LIB_KDEUI)