summaryrefslogtreecommitdiffstats
path: root/khotkeys/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'khotkeys/Makefile.am')
-rw-r--r--khotkeys/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/khotkeys/Makefile.am b/khotkeys/Makefile.am
new file mode 100644
index 000000000..981a8a9b6
--- /dev/null
+++ b/khotkeys/Makefile.am
@@ -0,0 +1,10 @@
+SUBDIRS = shared kcontrol app data update $(KHOTKEYS_ARTS_SUBDIR)
+
+khotkeys_autostart_DATA = khotkeys.desktop
+khotkeys_autostartdir = $(datadir)/autostart
+
+EXTRA_DIST = $(khotkeys_autostart_DATA) COPYING AUTHORS
+
+messages: rc.cpp
+ $(EXTRACTRC) kcontrol/ui/*.ui data/*.khotkeys >> rc.cpp
+ $(XGETTEXT) rc.cpp app/*.cpp shared/*.cpp shared/*.h kcontrol/*.cpp -o $(podir)/khotkeys.pot