summaryrefslogtreecommitdiffstats
path: root/khotkeys/arts/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'khotkeys/arts/CMakeLists.txt')
-rw-r--r--khotkeys/arts/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/khotkeys/arts/CMakeLists.txt b/khotkeys/arts/CMakeLists.txt
new file mode 100644
index 000000000..7cbf4eac3
--- /dev/null
+++ b/khotkeys/arts/CMakeLists.txt
@@ -0,0 +1,42 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+if( WITH_ARTS )
+ pkg_search_module( ARTS arts )
+ if( NOT ARTS_FOUND )
+ tde_message_fatal( "aRts are requested, but not found on your system" )
+ endif( )
+ set( HAVE_ARTS 1 CACHE INTERNAL "" FORCE )
+endif( )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/khotkeys/kcontrol
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/khotkeys/shared
+ ${CMAKE_SOURCE_DIR}/khotkeys/kcontrol
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${ARTS_LIBRARY_DIRS}
+)
+
+
+##### khotkeys_arts (module) #######################
+
+tde_add_kpart( khotkeys_arts AUTOMOC
+ SOURCES soundrecorder_arts.cpp voicerecorder_arts.cpp
+ LINK khotkeys_shared-shared artskde-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)