summaryrefslogtreecommitdiffstats
path: root/khotkeys/kcontrol/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'khotkeys/kcontrol/Makefile.am')
-rw-r--r--khotkeys/kcontrol/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/khotkeys/kcontrol/Makefile.am b/khotkeys/kcontrol/Makefile.am
new file mode 100644
index 000000000..81e691669
--- /dev/null
+++ b/khotkeys/kcontrol/Makefile.am
@@ -0,0 +1,40 @@
+SUBDIRS = ui
+
+kde_module_LTLIBRARIES = kcm_khotkeys.la kcm_khotkeys_init.la
+
+kcm_khotkeys_la_SOURCES = \
+ menuedit.cpp window_trigger_widget.cpp tab_widget.cpp main_buttons_widget.cpp \
+ actions_listview_widget.cpp menuentry_widget.cpp general_tab.cpp \
+ action_group_tab.cpp kcmkhotkeys.cpp command_url_widget.cpp windowdef_list_widget.cpp \
+ windowdef_simple_widget.cpp triggers_tab.cpp dcop_widget.cpp info_tab.cpp \
+ action_list_widget.cpp keyboard_input_widget.cpp condition_list_widget.cpp \
+ gesturedrawer.cpp gesturerecorder.cpp gesturerecordpage.cpp gesture_triggers_tab.cpp \
+ windowselector.cpp gestures_settings_tab.cpp general_settings_tab.cpp \
+ voicerecorder.cpp voicerecordpage.cpp voice_settings_tab.cpp
+
+kcm_khotkeys_la_LIBADD = ui/libui.la $(LIB_KDEUI) $(LIB_ARTS)
+kcm_khotkeys_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+
+kcm_khotkeys_init_la_SOURCES = init.cpp
+
+kcm_khotkeys_init_la_LIBADD = $(LIB_KDECORE)
+kcm_khotkeys_init_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+
+noinst_HEADERS = menuedit.h window_trigger_widget.h \
+ tab_widget.h main_buttons_widget.h actions_listview_widget.h menuentry_widget.h \
+ general_tab.h action_group_tab.h kcmkhotkeys.h windowdef_list_widget.h \
+ command_url_widget.h windowdef_simple_widget.h triggers_tab.h dcop_widget.h info_tab.h \
+ action_list_widget.h keyboard_input_widget.h condition_list_widget.h \
+ activate_window_widget.h \
+ gesturedrawer.h gesturerecorder.h gesturerecordpage.h gesture_triggers_tab.h \
+ windowselector.h gestures_settings_tab.h general_settings_tab.h \
+ voicerecorder.h voicerecordpage.h voice_settings_tab.h
+
+
+INCLUDES= -I$(top_srcdir)/khotkeys/shared -I$(srcdir)/ui -I./ui $(all_includes)
+
+METASOURCES = AUTO
+
+xdg_apps_DATA = khotkeys.desktop
+
+KDE_ICON = khotkeys