summaryrefslogtreecommitdiffstats
path: root/khotkeys/update/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'khotkeys/update/CMakeLists.txt')
-rw-r--r--khotkeys/update/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/khotkeys/update/CMakeLists.txt b/khotkeys/update/CMakeLists.txt
new file mode 100644
index 000000000..13a7dffca
--- /dev/null
+++ b/khotkeys/update/CMakeLists.txt
@@ -0,0 +1,31 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/khotkeys/shared
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### khotkeys_update (executable) ##############
+
+tde_add_executable( khotkeys_update
+ SOURCES update.cpp
+ LINK khotkeys_shared-shared
+ DESTINATION ${LIB_INSTALL_DIR}/kconf_update_bin
+)