summaryrefslogtreecommitdiffstats
path: root/kicker/applets/systemtray/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kicker/applets/systemtray/Makefile.am')
-rw-r--r--kicker/applets/systemtray/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/kicker/applets/systemtray/Makefile.am b/kicker/applets/systemtray/Makefile.am
new file mode 100644
index 000000000..849795a9e
--- /dev/null
+++ b/kicker/applets/systemtray/Makefile.am
@@ -0,0 +1,24 @@
+
+INCLUDES = -I$(top_srcdir)/kicker/libkicker $(all_includes)
+
+kde_module_LTLIBRARIES = systemtray_panelapplet.la
+
+systemtray_panelapplet_la_SOURCES = systemtrayapplet.cpp systemtrayapplet.skel
+
+systemtray_panelapplet_la_METASOURCES = AUTO
+noinst_HEADERS = systemtrayapplet.h
+
+lnkdir = $(kde_datadir)/kicker/applets
+lnk_DATA = systemtrayapplet.desktop
+
+EXTRA_DIST = $(lnk_DATA)
+
+systemtray_panelapplet_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+systemtray_panelapplet_la_LIBADD = ../../libkicker/libkickermain.la $(LIB_KDEUI) $(LIB_KIO)
+
+
+messages:
+ $(XGETTEXT) *.cpp *.h -o $(podir)/ksystemtrayapplet.pot
+
+srcdoc:
+ kdoc -a -p -H -d $$HOME/web/src/ksystemtrayapplet ksystemtrayapplet *.h -lqt -lkdecore -lkdeui -lkfile