summaryrefslogtreecommitdiffstats
path: root/kicker/applets/trash/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kicker/applets/trash/Makefile.am')
-rw-r--r--kicker/applets/trash/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/kicker/applets/trash/Makefile.am b/kicker/applets/trash/Makefile.am
new file mode 100644
index 000000000..a34f87d1c
--- /dev/null
+++ b/kicker/applets/trash/Makefile.am
@@ -0,0 +1,21 @@
+INCLUDES = -I$(top_srcdir)/libkonq -I$(top_srcdir)/kicker/libkicker $(all_includes)
+
+kde_module_LTLIBRARIES = trash_panelapplet.la
+trash_panelapplet_la_SOURCES = trashbutton.cpp trashapplet.cpp
+
+METASOURCES = AUTO
+
+noinst_HEADERS = \
+ trashapplet.h trashbutton.h
+
+lnkdir = $(kde_datadir)/kicker/applets
+lnk_DATA = trashapplet.desktop
+
+EXTRA_DIST = $(lnk_DATA)
+
+trash_panelapplet_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+trash_panelapplet_la_LIBADD = ../../libkicker/libkickermain.la ../../../libkonq/libkonq.la $(LIB_KDEUI) $(LIB_KIO) $(LIB_KUTILS)
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/trashapplet.pot
+