summaryrefslogtreecommitdiffstats
path: root/kicker/kicker/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kicker/kicker/CMakeLists.txt')
-rw-r--r--kicker/kicker/CMakeLists.txt58
1 files changed, 58 insertions, 0 deletions
diff --git a/kicker/kicker/CMakeLists.txt b/kicker/kicker/CMakeLists.txt
new file mode 100644
index 000000000..dc5053d5a
--- /dev/null
+++ b/kicker/kicker/CMakeLists.txt
@@ -0,0 +1,58 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+if( NOT BUILD_LIBKONQ )
+ include( "${TDE_CMAKE_DIR}/libkonq.cmake" )
+endif( NOT BUILD_LIBKONQ )
+
+add_subdirectory( core )
+add_subdirectory( interfaces )
+add_subdirectory( ui )
+add_subdirectory( buttons )
+
+include_directories(
+ ${CMAKE_SOURCE_DIR}/libkonq
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS} )
+
+link_directories( ${TQT_LIBRARY_DIRS} )
+
+
+##### other data ################################
+
+install( FILES panel.desktop DESTINATION ${AUTOSTART_INSTALL_DIR} )
+install( FILES kcmkicker.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+install( FILES kickerrc.upd DESTINATION ${DATA_INSTALL_DIR}/kconf_update )
+
+install( PROGRAMS
+ kicker-3.1-properSizeSetting.pl kicker-3.5-taskbarEnums.pl
+ kicker-3.5-kconfigXTize.pl
+ DESTINATION ${DATA_INSTALL_DIR}/kconf_update )
+
+
+##### kicker-3.4-reverseLayout (executable) #####
+
+tde_add_executable( kicker-3.4-reverseLayout
+ SOURCES kicker-3.4-reverseLayout.cpp
+ LINK kdecore-shared
+ DESTINATION ${LIB_INSTALL_DIR}/kconf_update_bin
+)
+
+
+##### kicker (kdeinit) ##########################
+
+configure_file( ${CMAKE_SOURCE_DIR}/cmake/modules/template_dummy_cpp.cmake dummy.cpp COPYONLY )
+
+tde_add_kdeinit_executable( kicker
+ SOURCES dummy.cpp
+ EMBED kicker_core-static
+ LINK kicker_buttons-static kicker_ui-static kickermain-shared kabc-shared kutils-shared
+)