summaryrefslogtreecommitdiffstats
path: root/kioslave/cgi/kcmcgi/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kioslave/cgi/kcmcgi/Makefile.am')
-rw-r--r--kioslave/cgi/kcmcgi/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/kioslave/cgi/kcmcgi/Makefile.am b/kioslave/cgi/kcmcgi/Makefile.am
new file mode 100644
index 000000000..abfef594b
--- /dev/null
+++ b/kioslave/cgi/kcmcgi/Makefile.am
@@ -0,0 +1,17 @@
+
+kde_module_LTLIBRARIES = kcm_cgi.la
+
+kcm_cgi_la_SOURCES = kcmcgi.cpp
+kcm_cgi_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+kcm_cgi_la_LIBADD = -lkdeui $(LIB_KIO)
+
+INCLUDES= $(all_includes)
+
+kcm_cgi_la_METASOURCES = AUTO
+
+noinst_HEADERS = kcmcgi.h
+
+xdg_apps_DATA = kcmcgi.desktop
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmcgi.pot