summaryrefslogtreecommitdiffstats
path: root/kioslave/fish/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kioslave/fish/CMakeLists.txt')
-rw-r--r--kioslave/fish/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/kioslave/fish/CMakeLists.txt b/kioslave/fish/CMakeLists.txt
new file mode 100644
index 000000000..77049ce8b
--- /dev/null
+++ b/kioslave/fish/CMakeLists.txt
@@ -0,0 +1,45 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include( ConfigureChecks.cmake )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES fish.protocol nxfish.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+##### kio_fish (module) #########################
+
+add_custom_command( OUTPUT fishcode.h
+ COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/genfishcode.pl ${CMAKE_CURRENT_SOURCE_DIR}/fish.pl > fishcode.h
+ DEPENDS fish.pl )
+
+set_property( SOURCE fish.cpp APPEND PROPERTY OBJECT_DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/fishcode.h )
+
+set( target kio_fish )
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES fish.cpp
+ LINK kio-shared util
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)