summaryrefslogtreecommitdiffstats
path: root/kioslave/fish/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kioslave/fish/Makefile.am')
-rw-r--r--kioslave/fish/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/kioslave/fish/Makefile.am b/kioslave/fish/Makefile.am
new file mode 100644
index 000000000..27308245b
--- /dev/null
+++ b/kioslave/fish/Makefile.am
@@ -0,0 +1,33 @@
+kde_module_LTLIBRARIES = kio_fish.la
+
+INCLUDES = $(all_includes)
+AM_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+
+kio_fish_la_SOURCES = fish.cpp
+kio_fish_la_LIBADD = $(LIB_KSYCOCA) #$(LIBUTIL)
+kio_fish_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+noinst_HEADERS = fishcode.h fish.h
+
+EXTRA_DIST = AUTHORS COPYING ChangeLog INSTALL README TODO FAQ fish.pl
+
+DISTCLEANFILES = fishcode.h
+
+kdelnk_DATA = fish.protocol nxfish.protocol
+kdelnkdir = $(kde_servicesdir)
+
+METASOURCES = AUTO
+
+fish.lo: fishcode.h
+
+fishcode.h: fish.pl
+ SUM=`$(MD5SUM) $(srcdir)/fish.pl | cut -d ' ' $(MD5SUM_CUT)`; \
+ echo '#define CHECKSUM "'$$SUM'"' > $@; \
+ echo 'static const char *fishCode(' >> $@; \
+ sed -e 's/\\/\\\\/g;s/"/\\"/g;s/^[ ]*/"/;/^"# /d;s/[ ]*$$/\\n"/;/^"\\n"$$/d;s/{CHECKSUM}/'$$SUM'/;' $(srcdir)/fish.pl >> $@; \
+ echo ');' >> $@;
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kio_fish.pot
+
+
+