summaryrefslogtreecommitdiffstats
path: root/kioslave/info/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kioslave/info/CMakeLists.txt')
-rw-r--r--kioslave/info/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/kioslave/info/CMakeLists.txt b/kioslave/info/CMakeLists.txt
new file mode 100644
index 000000000..f2dfb52e8
--- /dev/null
+++ b/kioslave/info/CMakeLists.txt
@@ -0,0 +1,39 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES info.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
+install( FILES kde-info2html.conf DESTINATION ${DATA_INSTALL_DIR}/kio_info )
+install( PROGRAMS kde-info2html DESTINATION ${DATA_INSTALL_DIR}/kio_info )
+
+
+##### kio_info (module) #########################
+
+set( target kio_info )
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES info.cc
+ LINK kio-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+