summaryrefslogtreecommitdiffstats
path: root/kioslave/man/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kioslave/man/CMakeLists.txt')
-rw-r--r--kioslave/man/CMakeLists.txt60
1 files changed, 60 insertions, 0 deletions
diff --git a/kioslave/man/CMakeLists.txt b/kioslave/man/CMakeLists.txt
new file mode 100644
index 000000000..6532f0cbf
--- /dev/null
+++ b/kioslave/man/CMakeLists.txt
@@ -0,0 +1,60 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+# FIXME not built: man2html, kio_man_test
+
+
+##### system checks #############################
+
+check_include_file( "unistd.h" HAVE_UNISTD_H )
+check_include_file( "string.h" HAVE_STRING_H )
+
+
+##### compiler/linker settings ##################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES man.protocol kmanpart.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+install( FILES kio_man.css DESTINATION ${DATA_INSTALL_DIR}/kio_man )
+
+
+##### kio_man (module) ##########################
+
+set( target kio_man )
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES man2html.cpp kio_man.cpp
+ LINK kio-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### libkmanpart (module) ######################
+
+set( target libkmanpart )
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES kmanpart.cpp
+ LINK khtml-shared kparts-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)