summaryrefslogtreecommitdiffstats
path: root/kioslave/media/mounthelper/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kioslave/media/mounthelper/CMakeLists.txt')
-rw-r--r--kioslave/media/mounthelper/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/kioslave/media/mounthelper/CMakeLists.txt b/kioslave/media/mounthelper/CMakeLists.txt
new file mode 100644
index 000000000..099a07764
--- /dev/null
+++ b/kioslave/media/mounthelper/CMakeLists.txt
@@ -0,0 +1,36 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/kioslave/media/libmediacommon
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### kio_media_mounthelper (executable) ########
+
+set( target kio_media_mounthelper )
+
+set( ${target}_SRCS
+ kio_media_mounthelper.cpp decryptdialog.ui dialog.cpp
+)
+
+tde_add_executable( ${target} AUTOMOC
+ SOURCES ${${target}_SRCS}
+ LINK mediacommon-static kio-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)