summaryrefslogtreecommitdiffstats
path: root/kioslave/pop3/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kioslave/pop3/CMakeLists.txt')
-rw-r--r--kioslave/pop3/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/kioslave/pop3/CMakeLists.txt b/kioslave/pop3/CMakeLists.txt
new file mode 100644
index 000000000..ed558f7cb
--- /dev/null
+++ b/kioslave/pop3/CMakeLists.txt
@@ -0,0 +1,37 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES pop3.protocol pop3s.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+##### kio_pop3 (module) #########################
+
+set( target kio_pop3 )
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES pop3.cc
+ LINK kio-shared ${SASL_LIBRARIES}
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)