summaryrefslogtreecommitdiffstats
path: root/kioslave/remote/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kioslave/remote/Makefile.am')
-rw-r--r--kioslave/remote/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/kioslave/remote/Makefile.am b/kioslave/remote/Makefile.am
new file mode 100644
index 000000000..073bfd12e
--- /dev/null
+++ b/kioslave/remote/Makefile.am
@@ -0,0 +1,32 @@
+SUBDIRS= . kdedmodule
+# wizard
+
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = kio_remote.la
+
+kio_remote_la_SOURCES = dummy.cpp
+kio_remote_la_LIBADD = libkioremote.la $(LIB_KIO)
+kio_remote_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) -no-undefined
+
+dummy.cpp:
+ echo > dummy.cpp
+
+kde_services_DATA = remote.protocol
+
+noinst_LTLIBRARIES = libkioremote.la
+libkioremote_la_SOURCES = kio_remote.cpp remoteimpl.cpp
+
+check_PROGRAMS = testremote
+testremote_SOURCES = testremote.cpp
+testremote_LDADD = libkioremote.la $(LIB_KIO)
+testremote_LDFLAGS = $(all_libraries)
+
+## TODO in unsermake: TESTS = testremote
+check: testremote
+ ./testremote
+
+messages:
+ $(XGETTEXT) `find . -name "*.cc" -o -name "*.cpp" -o -name "*.h"` -o $(podir)/kio_remote.pot
+