summaryrefslogtreecommitdiffstats
path: root/kioslave/trash/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kioslave/trash/CMakeLists.txt')
-rw-r--r--kioslave/trash/CMakeLists.txt59
1 files changed, 59 insertions, 0 deletions
diff --git a/kioslave/trash/CMakeLists.txt b/kioslave/trash/CMakeLists.txt
new file mode 100644
index 000000000..5dfd62cb2
--- /dev/null
+++ b/kioslave/trash/CMakeLists.txt
@@ -0,0 +1,59 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( kfile-plugin )
+
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES trash.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+##### trashcommon (static) ######################
+
+set( target trashcommon )
+
+tde_add_library( ${target} STATIC_PIC AUTOMOC
+ SOURCES trashimpl.cpp
+)
+
+
+##### kio_trash (module) ########################
+
+set( target kio_trash )
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES kio_trash.cpp
+ LINK trashcommon-static kio-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### ktrash (executable) #######################
+
+set( target ktrash )
+
+tde_add_executable( ${target}
+ SOURCES ktrash.cpp
+ LINK kio-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)