summaryrefslogtreecommitdiffstats
path: root/konqueror/client/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'konqueror/client/CMakeLists.txt')
-rw-r--r--konqueror/client/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/konqueror/client/CMakeLists.txt b/konqueror/client/CMakeLists.txt
new file mode 100644
index 000000000..e711e1f82
--- /dev/null
+++ b/konqueror/client/CMakeLists.txt
@@ -0,0 +1,43 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TDE_LIBRARY_DIRS}
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES kfmclient_3_2.upd DESTINATION ${DATA_INSTALL_DIR}/kconf_update )
+install( PROGRAMS kfmclient_3_2_update.sh DESTINATION ${DATA_INSTALL_DIR}/kconf_update )
+
+
+##### kfmclient (kdeinit) #######################
+
+set( target kfmclient )
+
+set( ${target}_SRCS
+ kfmclient.cc
+ ${CMAKE_SOURCE_DIR}/konqueror/KonquerorIface.stub
+ ${CMAKE_SOURCE_DIR}/kdesktop/KDesktopIface.stub
+)
+
+tde_add_kdeinit_executable( ${target} AUTOMOC
+ SOURCES ${${target}_SRCS}
+ LINK kio-shared
+)