summaryrefslogtreecommitdiffstats
path: root/konqueror/client/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'konqueror/client/Makefile.am')
-rw-r--r--konqueror/client/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/konqueror/client/Makefile.am b/konqueror/client/Makefile.am
new file mode 100644
index 000000000..97a5b66e4
--- /dev/null
+++ b/konqueror/client/Makefile.am
@@ -0,0 +1,23 @@
+AM_CPPFLAGS = -DQT_NO_CAST_ASCII
+
+bin_PROGRAMS=
+lib_LTLIBRARIES =
+kdeinit_LTLIBRARIES = kfmclient.la
+
+INCLUDES= -I.. $(all_includes)
+kfmclient_la_LDFLAGS = $(all_libraries) -module -avoid-version
+kfmclient_la_LIBADD = $(LIB_KIO)
+kfmclient_la_SOURCES = kfmclient.cc KonquerorIface.stub KDesktopIface.stub
+
+noinst_HEADERS = kfmclient.h
+METASOURCES = AUTO
+
+KonquerorIface_DIR = $(srcdir)/..
+KDesktopIface_DIR = $(top_srcdir)/kdesktop
+
+messages:
+ $(XGETTEXT) -kaliasLocal *.h *.cc -o $(podir)/kfmclient.pot
+
+updatedir = $(kde_datadir)/kconf_update
+update_DATA = kfmclient_3_2.upd
+update_SCRIPTS = kfmclient_3_2_update.sh