summaryrefslogtreecommitdiffstats
path: root/konsole/fonts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'konsole/fonts/Makefile.am')
-rw-r--r--konsole/fonts/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/konsole/fonts/Makefile.am b/konsole/fonts/Makefile.am
new file mode 100644
index 000000000..02f84b765
--- /dev/null
+++ b/konsole/fonts/Makefile.am
@@ -0,0 +1,16 @@
+fontdir = $(kde_datadir)/konsole/fonts
+font_DATA =console8x16.pcf.gz 9x15.pcf.gz
+
+EXTRA_DIST = $(font_DATA)
+
+# This uses -hook instead of -local so that it is run after fonts are installed
+install-data-hook:
+ -mkfontdir $(DESTDIR)$(fontdir)
+
+console8x16.pcf.gz: $(srcdir)/console8x16.bdf
+ bdftopcf -o console8x16.pcf $(srcdir)/console8x16.bdf
+ gzip --best console8x16.pcf
+
+9x15.pcf.gz: $(srcdir)/9x15.bdf
+ bdftopcf -o 9x15.pcf $(srcdir)/9x15.bdf
+ gzip --best 9x15.pcf