summaryrefslogtreecommitdiffstats
path: root/konsole/other/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'konsole/other/CMakeLists.txt')
-rw-r--r--konsole/other/CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/konsole/other/CMakeLists.txt b/konsole/other/CMakeLists.txt
index 2dc3214b4..58dcd038b 100644
--- a/konsole/other/CMakeLists.txt
+++ b/konsole/other/CMakeLists.txt
@@ -14,6 +14,15 @@ add_subdirectory( wallpapers )
tde_install_icons( )
+if( WITH_SUDO_KONSOLE_SUPER_USER_COMMAND )
+ set( KONSOLE_SUPER_USER_COMMAND "sudo su" CACHE INTERNAL "" FORCE )
+else()
+ set( KONSOLE_SUPER_USER_COMMAND su CACHE INTERNAL "" FORCE )
+endif()
+
+configure_file( su.desktop.cmake su.desktop @ONLY )
+configure_file( sumc.desktop.cmake sumc.desktop @ONLY )
+
install( FILES
BlackOnLightColor.schema BlackOnLightYellow.schema
BlackOnWhite.schema Example.Schema GreenOnBlack.schema
@@ -22,7 +31,9 @@ install( FILES
LightPicture.schema Transparent.schema GreenTint.schema
Transparent_MC.schema GreenTint_MC.schema Transparent_lightbg.schema
Transparent_darkbg.schema LightPaper.schema linux.desktop
- mc.desktop shell.desktop su.desktop sumc.desktop
+ mc.desktop shell.desktop
+ ${CMAKE_CURRENT_BINARY_DIR}/su.desktop
+ ${CMAKE_CURRENT_BINARY_DIR}/sumc.desktop
linux.keytab vt100.keytab vt420pc.keytab x11r5.keytab
solaris.keytab README.Schema README.KeyTab README.default.Keytab
screen.desktop