summaryrefslogtreecommitdiffstats
path: root/ksplashml/themeengine/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ksplashml/themeengine/Makefile.am')
-rw-r--r--ksplashml/themeengine/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/ksplashml/themeengine/Makefile.am b/ksplashml/themeengine/Makefile.am
new file mode 100644
index 000000000..411825cc9
--- /dev/null
+++ b/ksplashml/themeengine/Makefile.am
@@ -0,0 +1,18 @@
+SUBDIRS = . default standard redmond simple
+
+INCLUDES = -I$(srcdir)/.. $(all_includes)
+
+lib_LTLIBRARIES = libksplashthemes.la
+
+libksplashthemes_la_SOURCES = themeengine.cpp objkstheme.cpp
+libksplashthemes_la_LDFLAGS = $(all_libraries) $(KDE_RPATH) -no-undefined
+libksplashthemes_la_LIBADD = $(LIB_KDEUI) $(LIB_XCURSOR)
+METASOURCES = AUTO
+
+# install this header for theme developers.
+pkgincludedir = $(includedir)/ksplash
+pkginclude_HEADERS=themeengine.h objkstheme.h
+
+servicetypesdir = $(kde_servicetypesdir)
+servicetypes_DATA = ksplashplugins.desktop
+