summaryrefslogtreecommitdiffstats
path: root/kstart/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kstart/Makefile.am')
-rw-r--r--kstart/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/kstart/Makefile.am b/kstart/Makefile.am
new file mode 100644
index 000000000..01aeca492
--- /dev/null
+++ b/kstart/Makefile.am
@@ -0,0 +1,21 @@
+####### Fiddle here
+
+AM_CPPFLAGS = -DQT_NO_CAST_ASCII -DQT_CLEAN_NAMESPACE -DQT_NO_COMPAT
+
+INCLUDES = $(all_includes)
+
+####### Files
+
+bin_PROGRAMS = kstart
+kstart_SOURCES = kstart.cpp
+kstart_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+kstart_LDADD = $(LIB_KDECORE)
+METASOURCES = kstart.moc
+
+noinst_HEADERS = kstart.h version.h
+
+messages:
+ $(XGETTEXT) $(kstart_SOURCES) -o $(podir)/kstart.pot
+
+EXTRA_DIST = CHANGES LICENSE.readme
+