summaryrefslogtreecommitdiffstats
path: root/ksysguard/gui/ksgrd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ksysguard/gui/ksgrd/CMakeLists.txt')
-rw-r--r--ksysguard/gui/ksgrd/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/ksysguard/gui/ksgrd/CMakeLists.txt b/ksysguard/gui/ksgrd/CMakeLists.txt
new file mode 100644
index 000000000..5009bfcca
--- /dev/null
+++ b/ksysguard/gui/ksgrd/CMakeLists.txt
@@ -0,0 +1,43 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### headers ###################################
+
+install( FILES
+ HostConnector.h SensorAgent.h SensorClient.h
+ SensorManager.h SensorShellAgent.h SensorSocketAgent.h
+ StyleEngine.h StyleSettings.h TimerSettings.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/ksgrd )
+
+
+##### ksgrd (shared) ############################
+
+tde_add_library( ksgrd SHARED AUTOMOC
+ SOURCES
+ HostConnector.cc SensorAgent.cc SensorManager.cc
+ SensorShellAgent.cc SensorSocketAgent.cc StyleEngine.cc
+ StyleSettings.cc TimerSettings.cc
+ VERSION 1.2.0
+ LINK kdeui-shared
+ DESTINATION ${LIB_INSTALL_DIR}
+)