summaryrefslogtreecommitdiffstats
path: root/ksysguard/ksysguardd/FreeBSD/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ksysguard/ksysguardd/FreeBSD/CMakeLists.txt')
-rw-r--r--ksysguard/ksysguardd/FreeBSD/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/ksysguard/ksysguardd/FreeBSD/CMakeLists.txt b/ksysguard/ksysguardd/FreeBSD/CMakeLists.txt
new file mode 100644
index 000000000..b99088d1a
--- /dev/null
+++ b/ksysguard/ksysguardd/FreeBSD/CMakeLists.txt
@@ -0,0 +1,26 @@
+#################################################
+#
+# (C) 2015 Serghei Amelian
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/ksysguard/CContLib
+ ${CMAKE_SOURCE_DIR}/ksysguard/ksysguardd
+)
+
+
+##### ksysguardd (static) #######################
+
+tde_add_library( ksysguardd STATIC
+ SOURCES
+ CPU.c Memory.c ProcessList.c apm.c diskstat.c loadavg.c logfile.c netdev.c
+ LINK kvm
+)